Revenankh Sprite Problems

Status
Not open for further replies.
#1
Very often when I come into a battle with an enemy Revenankh, or if I use my own Revenankh, a strange dark blue box surrounds the sprite, and even some other sprites.






Is anybody else having this problem? I'd really like to know what I can do about it. =/

Edit: Showed it happening to my own Revenankh
 

KoA

The very best...
is an Artist Alumnus
#3
I find it funny that the sprites remembered the base background color I used to make them in. :/

Other than that, this is weird to me.
 

DougJustDoug

Knows the great enthusiasms
is a member of the Site Staffis an Artistis a Programmeris a CAP Contributoris an Administratoris a Battle Server Admin Alumnusis a Live Chat Contributor Alumnusis a Tiering Contributor Alumnus
CAP Leader
#4
It may be a problem with the color palette. All the normal game PNG's have 8-bit color. KoA's have 24-bit color. I'm looking into various PNG converters to clean this up.
 

DougJustDoug

Knows the great enthusiasms
is a member of the Site Staffis an Artistis a Programmeris a CAP Contributoris an Administratoris a Battle Server Admin Alumnusis a Live Chat Contributor Alumnusis a Tiering Contributor Alumnus
CAP Leader
#5
Can someone else look into this problem? I've got several other things going on and I think there are other people on this project that know about sprites and images and might be able to fix the issue. Here's a sprite that is known to be causing some problems:

 
#9
probably depends on whatever the image reading thing the java is using some can handle transparent colors others can not
 

DougJustDoug

Knows the great enthusiasms
is a member of the Site Staffis an Artistis a Programmeris a CAP Contributoris an Administratoris a Battle Server Admin Alumnusis a Live Chat Contributor Alumnusis a Tiering Contributor Alumnus
CAP Leader
#14
OK, we've fixed the problem. Something was wrong with the transparency on some of the sprites. On Obi's suggestion, I redid the transparency in Photoshop, and that seemed to do the trick.

If anyone is experiencing the problems described in this thread, please re-install the sprites using the CAP Sprite Updater. Instructions can be found here.
 
Status
Not open for further replies.