Problem running Pokelab - Unable to launch application

#1
Yeah, so basically what it says up there ^. I had no trouble downloading it, etc. but when I try to open it I get a message that says "unable to launch application." If I click on "details" it says that "java.lang.UnsupportedClassVersionError: Bad version number in .class file"

Any help?
 

Cathy

Banned deucer.
#2
This means that you need to install a newer version of Java. If you are using Mac OS X, you can only get your Java updates through Apple, and if your version of OS X is too old, you will not be allowed to upgrade. This is a behaviour of Mac OS X and unfortunately not something we can help you with. If you are using another operating system, you can upgrade at any time.
 

Cathy

Banned deucer.
#5
You are probably still running the program with your old version of Java. I can't really give you step by step instructions on how to fix this. It will depend on your operating system and I'm not even sure the steps to use in Windows. (I don't use Windows.) As a workaround you could try uninstalling your old versions of Java.
 
#6
I'm using a Mac os x 10.5.8. How do I uninstall old versions of Java? I was previously told you couldn't do it on Macs.

Edit: Uninstalled Java and reinstalled it. Removed versions 1.3/4. Still doesn't work. Should I reinstall Pokelab?
 
#8
I was playing a few minutes ago and had a battle freeze midway. I couldn't type in the battle window, or the main chat. I disconnected and when I reopen pokemonlab it shows the server at 200/500 but when I click connect nothing happens. About 15-20 seconds later i get a message saying disconnected from the server.
 
#9
I was playing a few minutes ago and had a battle freeze midway. I couldn't type in the battle window, or the main chat. I disconnected and when I reopen pokemonlab it shows the server at 200/500 but when I click connect nothing happens. About 15-20 seconds later i get a message saying disconnected from the server.

This is the exact same thing that happened to me

200/500 pop

Battle midway that freezes and can't log in

Message saying disconnected from server
 
#14
For those with Macs, you have to do a bit exploring, but once you find your Java Settings (I'm 99% sure you have it if you have Java), you have to change the priority of what version to load. I believe the computer automatically ranks your Java versions and you'll have to change the order of them using the arrow keys in the settings, I think.
 
#15
Fixed!

I somehow fixed it! I've been receiving the same exact message that SourMilk has been getting. I have the most current Java update and a Mac OS X 10.5.8 To solve it:
I opened up /Applications/Utilities/Java Preferences
Under the General tab, I saw this:
[✓] J2SE 5.0
[✓] Java SE 6
[✓] J2SE 5.0
[ ] J2SE 1.4.2
After un-checking the J2SE 5.0s and moving Java SE 6 to the top, I re-opened Pokelab and it worked perfectly!
 
#17
Download and install the client and then double click Beta Server on the server list. You are brought to a log-in screen. Use your Smogon forums account name and password to log in. The advanced connection information, if needed, is Host: smogon.com, Port: 8446.
 
#18
i have mac os x 10.5.8 and whenever i try to open pokemon lab (yes i tried valorum27's idea) it still says "unable to launch the application" and under details it says "java.lang.UnsupportedClassVersionError: Bad version number in .class file"
please help!
 
#20
I have had this exact same problem before. If your problem is the same as mine, here is what you need to do.

First you need to go to your control panel and click on Java. Go to where it says temporary internet files, and click View. Next to where it says "Show" click on Deleted applications. Select Pokemon Lab and click on the icon that says restore. After this, you should not still have this problem. Hope i helped.
 
#21
Nothing suggested so far worked for me. Windows 7, latest version of Java updated. The download link on smogon forums dosen't seem to be working either (this could be one of my google chrome screw ups)
 

Users Who Are Viewing This Thread (Users: 1, Guests: 0)