Bug Reports v4 [READ ORIGINAL POST before posting]

"/om blitz" is outdated. It reads:
Super-fast 'Blitz' timer giving 30 second Team Preview and 10 seconds per turn.
No ruleset found for Blitz
The blitz timer is currently 40 seconds for Team Preview and 15 seconds per turn, as stated at the start of a blitz game. The "no ruleset found for blitz" also seems extraneous.

BUG STATUS: NOT A BUG, The timer for blitz hasn't changed. This description is correct, despite what it looks like. It shows otherwise because 15 seconds is the seconds you start with on the first turn, and 10 seconds is the amount of seconds you have thereafter. (Dawn of Ares)
 
Last edited by a moderator:
Just had a Random-Battle (Gen 8) where I used Outrage, and got locked in, then they protected and I was unlocked from Outrage without getting confused (Life Orb Flygon vs Salazzle. No Misty Terrain). I think I should have gotten confused, but I’m not sure.

Replay:
https://replay.pokemonshowdown.com/gen8randombattle-1259629329-32e8wt4lvn5mwf00y89xcqb0lmvc7hnpw

BUG STATUS: NOT A BUG, If Outrage gets interrupted before the turn it is supposed to end, i.e. hitting a fairy type or protect, it will not confuse the user. This also goes for thrash. (Dawn of Ares)
 
Last edited by a moderator:
/modchat whitelist doesn't seem to work properly, showing whitelisted users who speak in them "Because moderated chat is set, you must be of rank Whitelist or higher to speak in this room."

BUG STATUS: CONFIRMED - CHAT (SERVER) (Mia)
 
Last edited by a moderator:
Found a bug involving weather ball in generation III. On showdown, an opponent using counter will always deal double damage when hit by weather ball. The in-game behavior is that it won't be countered if weather ball is a special type. I can only assume this happens because of the interaction between hidden power and counter, which works the same on showdown as it does in-game. I can provide footage of these interactions in-game if requested. https://replay.pokemonshowdown.com/gen3ou-1259102748-12u9rxgi8nceav7vt2c6nvdyiws5cropw

footage provided by DarkShinyGiratina

BUG STATUS: CONFIRMED - MECHANICS (SERVER), thanks for the footage! (DaWoblefet)
 
Last edited by a moderator:
My Porygon-Z used Max Strike (which is Tri Attack), but finally, it comes out as Max Lighting.....


Screenshot 2021-01-11 at 2.18.53 PM.png

BUG STATUS: NOT A BUG, Plasma Fists turns Normal-type moves into Electric-type moves, including Max Moves (DaWoblefet)
 
Last edited by a moderator:
https://replay.pokemonshowdown.com/gen8balancedhackmons-1260070105

My Zygarde outsped the opposing Kyogre, which should be impossible. The Kyogre's item was Leftovers, I had an Assault Vest. Apparently Zygarde's Sassy (-speed, +spdef) nature got lost in the system somewhere, defaulting it to a Careful (neutral) nature.
When I outsped the Kyogre first, I immediately went to the teambuilder, where Zygarde had 0 speed EVs, 0 speed IVs and a Sassy nature as expected, so it couldn't have been myself, messing up my sets. However, as later revealed in the game, my Zygarde apparently had a Careful nature, setting my speed at 175, which is higher than Kyogre's min speed of 166.

BUG STATUS: NOT A BUG, I checked both teams and Zygarde was in fact using a Careful Nature during this battle, so the behavior with Speed was expected. You must have just gone into the battle with Careful without realizing it (DaWoblefet)
 
Last edited by a moderator:
When using Galarian weezing with a hidden ability transfer move (such as zap cannon), an incompatibility error occurs (as shown in the file).
However, because weezing did not have a hidden ability when the VC games were released, koffing from virtual console receive their regular ability slot (Levitate), and can have a transfer move.
This should mean with the addition of ability capsules/patches in generation 8, a koffing that is transferred to Sword and Shield then evolved into its Galarian Form, shouldn't have any issues with virtual console move and ability compatibility.
By contrast, regular weezing does not have this problem, so I believe it to be an oversight.

BUG STATUS: CONFIRMED - LEGALITY (DaWoblefet). See also this post for some explanation; in DLC1, Weezing should be able to use Virtual Console moves only without its HA.

Weezing-Galar
Ability: Neutralizing Gas
EVs: 68 HP
IVs: 0 Atk
- Zap Cannon
 

Attachments

Last edited by a moderator:
https://replay.pokemonshowdown.com/gen8metronomebattle-1257279823
On Turn 7, I am imprisoned and forced to Struggle. Despite this, I still have the working option to dynamax when I should not be able to.

EDIT: It just happened again, so now I have a screenshot. It seems to work with either slot, and actually lets me choose Max Guard on further turns of dynamax.
https://replay.pokemonshowdown.com/gen8metronomebattle-1257282531-lho4y5if69ivgn052rkyc1uu6v3bvk0pw

EDIT 2: Same goes for Torment. (Turn 4)
https://replay.pokemonshowdown.com/gen8metronomebattle-1257291056

BUG STATUS: CONFIRMED - MECHANICS (SERVER) (Dawn of Ares)
I would like to add that the client shows max guard like this in these scenarios

Screen Shot 2021-01-11 at 10.40.50 AM.png
(this is the prompt for the 2nd deoxys)

full replay: https://replay.pokemonshowdown.com/gen8metronomebattle-1260149162
 

Cheese5555

too cheesy
is a Tiering Contributor
Puzzle Hunt Champion
1610397972259.png

i hadn't joined this tour yet but i had joined a previous one in the room and lost first round, not sure why it picked giove97 in particular. (this problem is ui only as upon pressing button i get a "This tournament has not started yet.")
 
The ability Queenly Majesty is supposed to protect the Pokémon with the ability, as well as all of its allies, from priority moves.

And, indeed, that is how it is programmed into PS. Not bugged.

However, the description of the ability in the teambuilder is written to say that it only protects its allies, not itself. (Or at least, that's how I read it.)

Could be made more clear, as an initial reading implies that this does nothing outside of Doubles.

BUG STATUS: WRONG PLACE, this is more of a suggestion (DaWoblefet)
 
Last edited by a moderator:
A Pokemon with Scrappy that can use Brick Break (I was using a Kangaskhan), can not break the screens of a Ghost type.

https://replay.pokemonshowdown.com/gen8ou-1260489403

The description of Brick Break is "Destroys screens, unless the target is immune". Scrappy bypasses the immunity of the Dragapult, so that means the immunity is ignored, and screens are supposed to break. Versus a regular target all present screens that are set up will break- this is not the case with the Scrappy Kangaskhan vs. Dragapult situation. I'm totally sure this is a bug since it may have not been coded into PS properly or am I just dumb?

 

Distrib-PS

formerly theod1
The -otd commands seem to have a problem when someone has a certain symbols in their username (I'm guessing it's just ones that mess with HTML).

Here, the user called Ishtar<33 truncates that list item early and makes the following list items all be in italics instead of only the "Submitted by..." part. This is from the /anotd command and only with the '<' character, but it should be extendable to all the -otd commands and other characters.
Fixed Thx!
 

Distrib-PS

formerly theod1
Hey !
We can not display help commands (for exemple !h poll & !help poll)
recording (2).gif
Maybe in the Client ?
Mia edit: client doesn't handle this, I'll fix it
 
Last edited by a moderator:
If you can only use Struggle, you cannot Dynamax, Mega Evolve, or use a Z-move.
Replay (Turns 18-20): https://replay.pokemonshowdown.com/gen8unratedrandombattle-1260774644

Unless I'm misreading/misunderstanding that behavior, once CB Urshifu's Sucker Punch gets disabled it shouldn't be able to dynamax because it can only use Struggle. For whatever reason I was able to dynamax except I used Struggle on the first turn, then the next turn I was free to use my Max Moves.

The UI showed something different (pictures under hide tag) than what what actually happened in the battlebecause once I chose to Dynamax (which I shouldn't have been able to) Struggle changed to become a normal-type Max Darkness, even though the move actually executed is Struggle. Afterwards the Dynamax moves displayed normally and I was able to use them, as shown in the replay. Some pictures included under the hide tag.
1610504880279.png

Displays what I see when I can only struggle, but Dynamax is still click-able

1610505070999.png

Once I choose to dynamax, I get the option to use Max Darkness (because my first move was dark-type, I tried it with Close Combat as the first move and the text changed to Max Knuckle), but as seen from the replay this just attacks with Struggle

1610505503568.png

When trying to recreate this (using a Dark-type move in the first slot), I realized that upon hovering it actually displays the info for Max Strike (also displays as a normal-type move), which is another inconsistency.
 

pokeblade101

Smogoff Kickoff Tour Winner
Not sure if this was reported before but there is an issue with how tooltip works for past gens for what I assume is all moves.

The moves on the tooltip for past gens uses the gen 8 descriptions which can be quite misleading for several people in battle.

I've tested in all gens but here are a few with Rapid Spin and Knock Off. The power of the moves are correct but tooltip just uses the gen 8 descriptions instead of their current gen mechanic descriptions.

Screenshot (74).png

Screenshot (75).png

Screenshot (77).png

Screenshot (73).png
 
I have a bug that is quite annoying in the balanced hackmons tier (a somewhat common set abuses this).
According to the Bulbapedia pages for both perish song and soundproof:
"Pokémon with Soundproof are no longer immune to their own moves; consequently, if a Pokémon uses Perish Song, it will now gain a perish count even if it has Soundproof."
Pokemon showdown does not behave this way. Here is a replay to illustrate
And an example of how this bug technically exists outside of BH

BUG STATUS: CONFIRMED - MECHANICS (SERVER) (Dawn of Ares)
 
Last edited by a moderator:
PPs don't deplete after the first use when using Sleep Talk with a locking item in DPP.
This is most likely related to Sleep Talk always failing when used multiple times with a locking item.

Since this is an awkward behaviour on an older generation I tested it on cartridge, PPs do deplete, and it does make you struggle when it hits 0.

On Sim, you just get to click Sleep Talk as many times as you want :
https://replay.pokemonshowdown.com/gen4ubers-1261471016-as3bggug5orerr8w1ifyswzz335cg5epw
(PPs deplete on the public tooltip but not on the actual user's side, you can go to as much negative PPs as you want)

BUG STATUS: CONFIRMED - MECHANICS (SERVER), thanks for the cartridge footage! (DaWoblefet)
 
Last edited by a moderator:
what.png

i was playing a game of gen 8 ou, and burned obstagoon on the switch, he is at full health and none of his moved are revealed, so it's the frist time he's switched in, and his item was revealed as flame orb? this is weird, i dont think there was any reason for his item to be revealed, https://pokepast.es/b38f43b748db1899 is the team i was running, so i had no way to reveal items to my knowledge. i dont have a replay saved unfortunately. i tried to recreate the bug but it didnt work?

BUG STATUS: NOT A BUG, it was revealed because Flame Orb burned the Obstagoon. If you can get a replay showcasing otherwise, that would be helpful (DaWoblefet)
 
Last edited by a moderator:
Last edited by a moderator:

Users Who Are Viewing This Thread (Users: 1, Guests: 1)

Top