1. Remember to check the Simple Questions/Simple Answers , Suggestions , Bug Reports and Technical Support threads before posting. If you have something that warrants extended discussion then post a thread, but when in doubt, please use an already existing thread
  2. Welcome to Smogon! Check out the Smogon Starters Hangout for everything you need to know about starting out in the community. Don't forget to introduce yourself in the Introduction and Hangout Thread, too!
  3. Welcome to Smogon Forums! Please take a minute to read the rules.

Technical Support Mk. 2 (READ OP BEFORE POSTING!)

Discussion in 'Pokémon Showdown!' started by Antar, Jul 22, 2012.

  1. Antar

    Antar Self-anointed Czar of LC UU
    is a Battle Server Administratoris a Programmeris a Super Moderatoris a Community Contributor
    Official Data Miner

    Joined:
    Feb 17, 2010
    Messages:
    3,177
    Introduction

    Before you try anything else, if something's not working, see if it's fixed by connecting via HTTPS; copy/paste this into your URL bar: https://play.pokemonshowdown.com/

    This thread is dedicated to technical support for Pokemon Showdown. This is not the place to post bug reports or feature requests--the only things that should go in this thread are requests for help doing something that you should be able to do already, like connect to the server or stay connected.

    Also, if you are having trouble connecting, make sure that the login server isn't just down by clicking this link.

    PS is still in development, so we may not have the answer to all your questions, but we'll try, and the information you provide should help us identify problem areas.

    Rules

    If you post a support request in this thread, it must contain the following information. If it does not, it will be deleted. If the information is irrelevant to your request/question, it probably belongs in Simple Questions, Simple Answers

    Please include the following information in your question:
    1. Operating system
    2. Web Browser (with version, if you know it)
    3. Have you tried other browsers? If so, which one, and does this problem happen on them as well?
    4. When did this problem start?
    5. Your PS username
    6. And of, course, your problem (include any error messages verbatim. give frequency, etc.).

    In addition, you should not post if...
    • ...your question is answered already in the FAQ post in this thread.
    • ...you have a bug to report that's not technical, such as an error in tiering, Dream World ability releases, commands not working, etc. Make a new thread for each of those so that we can guarantee that they'll be seen.
    • ...you have a suggestion for Showdown. The suggestions thread is here.
    • ...your question has ANYTHING to do with the ladder or ratings. The ladder is in active development and is known to have problems.
    • ...you want to ask a question about Shoddy Battle, Pokemon Laboratory or Pokemon Online. Smogon doesn't support the first two any more, and PO has its own forum.
    • ...you want to report driver / moderator / administrator power abuse or would like to appeal a ban. Do so here and not in this thread.
    • ...you don't know what Pokemon Showdown is, or you want to download it. Please refer to this thread.

    The easiest way for you to make a post like this is to quote-reply to the next post, remove the quote tags, and fill in the relevant information.
    Last edited by a moderator: Oct 26, 2014
    LurkingBird+ and Grey Knight like this.
  2. Antar

    Antar Self-anointed Czar of LC UU
    is a Battle Server Administratoris a Programmeris a Super Moderatoris a Community Contributor
    Official Data Miner

    Joined:
    Feb 17, 2010
    Messages:
    3,177
    1. Operating system
    2. (Web Browser)
    3. (Other Browsers?)
    4. (When did this problem start?)
    5. (PS username)
    6. (Problem)
  3. Antar

    Antar Self-anointed Czar of LC UU
    is a Battle Server Administratoris a Programmeris a Super Moderatoris a Community Contributor
    Official Data Miner

    Joined:
    Feb 17, 2010
    Messages:
    3,177
    FAQ
    This will be filled in as we come up with the answers.

    List of Supported Browsers
    • Chrome
    • Firefox
    • Safari
    • Safari for iPhone/iPod/iPad
    • Opera
    • Firefox for Android

    List of Browsers Known Not to Work
  4. Mew

    Mew

    Joined:
    Jun 7, 2010
    Messages:
    488
    Show Hide
    [​IMG]

    I keep getting this whenever I try to go to Pokemon Showdown. On the mac download, Mozilla Firefox, Google Chrome and Safari.

    I've tried from other mac systems with my home's internet connection, and that seems to work. It only seems to work on user accounts with admin rights, but I am not able to get those.

    This all started since about two days ago, have you changed anything which causes this at my end?

    Please help! I really want to play on PS!!
  5. Zacchaeus

    Zacchaeus
    is a Battle Server Moderator Alumnus

    Joined:
    Dec 5, 2009
    Messages:
    3,259
    1. Operating system Windows 7
    2. (Web Browser) IE9
    3. (Other Browsers?)
    4. (When did this problem start?) A week or two ago
    5. (PS username)
    6. (Problem) Same problem as Mew
  6. fatsnorlax

    fatsnorlax

    Joined:
    Jun 18, 2011
    Messages:
    449
    Operating System-Windows 7
    Browser-Chrome-not known-think I've had browser since new year and haven't updated
    Started-Today
    Username-fatsnorlax
    Problem-ditto mew
    I was DCd yesterday, and didn't immediatly reconnect.... this problem has been plaguing me for the day...
  7. Ketsuban

    Ketsuban

    Joined:
    Oct 9, 2011
    Messages:
    126
    Chrome downloads new updates behind the scenes (unless you turn that functionality off) and applies them when you relaunch it. As such, there's not much need to specify a version number since most everyone just uses "Chrome"; anyone using the beta or dev channels knows they're doing so because they opted into it and can specify that they're using e.g. *checks about box* Chrome 22.0.1207.1 dev-m when reporting bugs.
  8. Kiyo

    Kiyo

    Joined:
    Feb 22, 2012
    Messages:
    484
    Same thing on my mac, although i haven't tried on any other systems yet.
  9. Hanketsu7787

    Hanketsu7787

    Joined:
    Jul 22, 2012
    Messages:
    9
    1. Windows 7
    2. Chrome
    3. Opera and Firefox 8
    4. Around 4 pm
    5. Saucy Wench
    6. Every time I try to connect, it says disconnect detected.
  10. Bryce

    Bryce Lun

    Joined:
    Mar 21, 2012
    Messages:
    442
    I am having the same problem.

    Operating system Windows xp
    (Web Browser) Google chrome
    (Other Browsers?)
    (When did this problem start?) a few days ago
    (PS username)RS White Symphoni
    (Problem) The one which I QUOTE
    __________________
    XD
  11. Sambobz

    Sambobz

    Joined:
    Feb 25, 2011
    Messages:
    93
    Win7
    Chrome
    Others: safari, opera, IE9
    I've had this problem since the beginning of time.
    username = ★ce

    I cannot get PS to work with chrome.

    "Joining showdown server... "
    then: "You have been disconnected - possibly because the server was restarted."

    PS kinda works with IE but it is so laggy I can't really play normally.
    Sarfari works better but it stops working after a few minuets the page just goes black(pretty sure this is just safari, not PS.) Opera and firefox have the same problem as chrome.

    I have tried un-installing and then re-installing twice, that didn't work.
  12. Bryce

    Bryce Lun

    Joined:
    Mar 21, 2012
    Messages:
    442
    Zarel can you please tell us how much you have advanced in solving our connection issue?
  13. CrackinSkulls

    CrackinSkulls

    Joined:
    Mar 2, 2012
    Messages:
    208
    Windows7
    Google Chrome
    Safari and Firefox
    When the server came back up after the DDoS
    Dove97
    Disconnecting every 2 mins
  14. Zarel

    Zarel Not a Yuyuko fan
    is a member of the Site Staffis a Battle Server Administratoris a Programmeris a Pokemon Researcheris an Administrator
    Creator of PS

    Joined:
    Aug 16, 2011
    Messages:
    1,897
    It should be working again.
  15. CrackinSkulls

    CrackinSkulls

    Joined:
    Mar 2, 2012
    Messages:
    208
    No it isn't :(. When i started it up it was working and then after 20 mins it just looped my last command like i posted in my bug report. After that it disconnects again. I will quote my bug report for you.


    and

    Show Hide
    [​IMG]
  16. Gone to the beach

    Gone to the beach

    Joined:
    Feb 8, 2012
    Messages:
    83
    problem resolved by mod online.
  17. limmengkang

    limmengkang

    Joined:
    Jul 30, 2012
    Messages:
    3
    Am I the only one who still gets the reconnect message? It happening every 20 seconds and is impossible to play. I tried it on all browsers and my username is LMK
  18. Zarel

    Zarel Not a Yuyuko fan
    is a member of the Site Staffis a Battle Server Administratoris a Programmeris a Pokemon Researcheris an Administrator
    Creator of PS

    Joined:
    Aug 16, 2011
    Messages:
    1,897
    I've heard several people talk about the "disconnect every few minutes" issue, but I don't personally have that problem (I think most people don't), so I don't know how to fix it.

    I've heard that it's only been happening since the DDoS attacks, but since then, there've been no changes likely to cause it.

    I think I'm going to need someone who does experience it to help test.

    When you see the "Disconnected" menu, instead of hitting "Reconnect", open the developer console. In most browsers, this is F12. If that don't work, try Opt+Cmd+I or Ctrl+Shift+I.

    Assuming Chrome, in the bottom right, you should see red circle next to a number: http://d.pr/i/vDgF

    Click the number, and it should show an error message. Tell me the error message.

    If there's no red circle, that's going to make things a lot harder to fix. :/
  19. CrackinSkulls

    CrackinSkulls

    Joined:
    Mar 2, 2012
    Messages:
    208
    will do

    Does this help?: "Unexpected response code: 400"
  20. limmengkang

    limmengkang

    Joined:
    Jul 30, 2012
    Messages:
    3
    It says "Uncaught Error: INVALID_STATE_ERR "

    Edit: The Second time i needed to reconnect no error or red dot showed up
  21. TIO

    TIO

    Joined:
    Jul 30, 2012
    Messages:
    742
    I have the same error as pretty much everybody here.
    Windows 7
    Chrome
    Nope.
    Today, which is the first time I tried PS.
    I don't have a username yet, because I keep being disconnected before I can get to round 3 in a battle.
  22. Sardiini777

    Sardiini777

    Joined:
    Nov 13, 2010
    Messages:
    152
    I have the same problem. I have to reconnect every minute. So annoying.
  23. TIO

    TIO

    Joined:
    Jul 30, 2012
    Messages:
    742
    OS, browser, etc.?
  24. Doman

    Doman

    Joined:
    Jan 5, 2007
    Messages:
    11
    (Operating system) Windows 7
    (Web Browser) Chrome (version 21.0.1180.60)
    (Other Browsers?) Tried in IE9. Same problem.
    (When did this problem start?) Last night, August 2 2012.
    (PS username) Doman
    (Problem) Pretty much the exact same problem that Mew has - I always get disconnected while on the login screen, during the "Connecting to Showdown Server..." step. Or rather, it was working entirely normally the first few days I used it (started on August 1, 2012), then disconnected me and my brother (PS username: SteamedRat) in the middle of a match. Neither of us have been able to successfully connect once since. There is no 'red circle' on the developer console as described in Zarel's post. downforeveryoneorjustme says it's just me.
  25. spelle123

    spelle123

    Joined:
    Mar 5, 2012
    Messages:
    18
    can some1 help me with a issue i have?: when i try to log in it just stops at "Connecting to showdown server" then i dc it has been working fine the last days untill now, im using chrome on a mac

Users Viewing Thread (Users: 0, Guests: 0)