• The moderators of this forum are the PS! staff.
  • Welcome to Smogon! Take a moment to read the Introduction to Smogon for a run-down on everything Smogon.

Bug Reports v3 [READ ORIGINAL POST before posting]

Merritt

literally the textbook definition of a tsundere
is a member of the Site Staffis a Forum Moderatoris a Community Contributoris a Contributor to Smogon
Moderator
Normalize is boosting the damage of all moves, not just non-Normal moves that are turned Normal. I thought it might be just a bug with the mouseover info, so I tested it.

https://replay.pokemonshowdown.com/gen7customgame-916827622

These Lonely Guzzlords are Banded, have 0 Defense IVs, and 252 Attack and HP EVs. Despite Thrash dealing a bit more damage, that's just due to damage rolls. According to the calculator, the maximum a non-Normalize Thrash or Dragon Ascent can do is 507.

According to Bulbapedia, moves that are already Normal-type shouldn't receive a boost. However, because this "bug" has existed for quite some time, the Smogon Ability Dex implies that the boost happens regardless of the original move's type, and Normalize is a pretty obscure ability that probably no one but Smogon would research in-depth, there's a very real possibility that this isn't a bug and Bulbapedia is wrong.
Bulbapedia is incorrect. All moves (with the exception of moves that can change type like Judgment or Weather Ball, even if they remain Normal, as well as CFZ moves) even if they were Normal-type originally, get the Normalize boost.

e: here's a link to the original research on smogon: https://www.smogon.com/forums/threads/pokemon-sun-moon-battle-mechanics-research.3586701/post-7125289
 

Perish Song

Can count up to 3
is a Pre-Contributor
Bulbapedia is incorrect. All moves (with the exception of moves that can change type like Judgment or Weather Ball, even if they remain Normal, as well as CFZ moves) even if they were Normal-type originally, get the Normalize boost.

e: here's a link to the original research on smogon: https://www.smogon.com/forums/threads/pokemon-sun-moon-battle-mechanics-research.3586701/post-7125289
There are actually no implications of Normalize that it doesn't boost Normal-type attacks in Bulbapedia. It is stated in the very first sentence that "Normalize makes all moves (including status moves) used by the Pokémon with this Ability act as though they were Normal-type instead of their usual type." This sounds a bit weird but it is not wrong to assume Normalize turns Normal-type attacks into Normal-type. The only explanation made there were the exceptional moves that the ability does not affect which are listed as Z-moves, Hidden Power, Weather Ball, Natural Gift, Judgment, Multi-Attack and Techno Blast. I ran this test myself to basically verify this so can say it is working as intended, Bulbapedia wasn't just clear enough.

In this replay you can see that 2 moves were used with the same base power, Multi-Attack deals less damage because it is indeed not affected by the Normalize, while Rock Climb hits harder with the damage boost it gets from Normalize.
 
Last edited:
It doesn't say that Haze blocks Mist, it says that in RBY Haze used to remove the protection of Mist entirely, something it no longer does. Haze will still remove stat boosts during Mist, it's just that until Mist expires naturally, you can't follow that up with explicit stat drops like Screech or Intimidate-switching.
 
Turn 97 in challenge cup: Shedninja had used mimic on my florges' hp ice so it should have about 9/24 pp left for hp ice. It seems like it measured how much pp was left for hp ice on florges because it used struggle instead.
http://replay.pokemonshowdown.com/gen7challengecup1v1-918114031
Mimic doesn’t copy the maxed pps of hidden power, hidden power with maxed pps has 24 pps whereas hidden power without maxed pps has 15 pps.

EDIT: I guess it could be counted as a bug, it doesn’t show how many actual pps a move has after it has been copied by mimic
 
If you only have three attacks chosen, the auto EVs and Nature (but not IVs) seem to assume you have a physical attack, even if you don't. The following spreads were all auto-generated:

Blacephalon
Ability: Beast Boost
EVs: 4 Atk / 252 SpA / 252 Spe
Hasty Nature
IVs: 0 Atk
- Shadow Ball
- Flamethrower
- Calm Mind

Blacephalon
Ability: Beast Boost
EVs: 252 SpA / 4 SpD / 252 Spe
Timid Nature
IVs: 0 Atk
- Shadow Ball
- Flamethrower
- Calm Mind
- Substitute

Chansey (F)
Ability: Natural Cure
EVs: 248 HP / 8 Atk / 252 Def
Impish Nature
- Soft-Boiled
- Toxic
- Seismic Toss

Chansey (F)
Ability: Natural Cure
EVs: 248 HP / 252 Def / 8 SpD
Bold Nature
- Soft-Boiled
- Toxic
- Seismic Toss
- Stealth Rock

Garchomp
Ability: Sand Veil
EVs: 252 Atk / 4 SpD / 252 Spe
Jolly Nature
- Earthquake
- Dragon Claw
- Fire Fang

EDIT: Actually, I just realized that Seismic Toss counts as a physical move for the auto IVs. That should also be fixed.
 

pre

no unforced errors
is a Battle Simulator Administratoris a Community Leaderis a Programmer
Community Leader
https://replay.pokemonshowdown.com/gen1randombattle-919867589
turn 5: Ditto used Transform!
Ditto transformed into Gengar!
[Ditto's none]
Code:
|move|p2a: Gengar|Thunderbolt|p1a: Ditto
|-damage|p1a: Ditto|46\/100
|move|p1a: Ditto|Transform|p2a: Gengar
|-transform|p1a: Ditto|p2a: Gengar
|-endability|p1a: Ditto|none|[from] move: Transform
https://github.com/Zarel/Pokemon-Showdown/blob/master/sim/pokemon.ts#L1433 needs to have a check like
https://github.com/Zarel/Pokemon-Showdown/blob/master/sim/pokemon.ts#L1438 around it. Though really, the entirety of SetAbility should be short circuited before gen 3

EDIT: This should be fixed after the next /hotpatch battles or server restart happens
 
Last edited:

Perish Song

Can count up to 3
is a Pre-Contributor
http://replay.pokemonshowdown.com/gen7ou-920404570
Showdown has the berry on drampa active before beserk nulling the ability effect. When in the actual games it's the ability that actives then the berry.
This report is somehow misleading because what you claim and what happened in the replay are exactly the opposite. As I understand, you stated that berry activates before berserk and nullifying the ability effect, which did not happen in the replay you provided. Instead, Berserk goes first then after the second hit the berry is activated.

If we happen the presume the otherwise ( where berry activates first thus canceling the ability), there is a slight error without replay that Guardian of Alola didn't take 75% exact hp of Drampa, leaving it above 25% thus canceling the berry effect. I tested this myself and can confirm its working as intended if that's what you mean.

https://replay.pokemonshowdown.com/gen7ou-920415364
 
The fist hit did not ative the berry cause it was just over the required amount to active. In your replay the order should have been beserk activing and then the berry healing is the order is what I'm refering to.
 
The nicks of my pokemon are incorrect; two of them are named after what I inherit from. And my Celesteela is nicked vikavolt, which isn’t even what I’m inheriting from
FD4A35DD-946A-4EA8-BFED-10A18C80998D.png8C2AB508-D93E-4003-979C-887843B17FC9.png
 
tried to start a PU match. i had my team picked and everything, and when i hit the battle button, it gave me the first error (The Pokemon "" does not exist.)

then i went into teambuilder to doublecheck that nothing broke, and apparently PS made a team with no pokemon in it. it had the [?] icon originally, but when i went into the team then left, it switched to the (empty team).

tl;dr PS makes itself a team with nothing in it, randomly switched from my regular team to it when i tried to start a battle. started another battle with no issues
 

Attachments

Users Who Are Viewing This Thread (Users: 1, Guests: 0)

Top