Technical Support v2 [READ ORIGINAL POST before posting]

Server maintenance is now complete! Thank you for your patience in this matter, things should work alot better now.
Is Dynamax banned?
I still am able to dynamax in battles, and was disappointed because I was looking forward to dynamax-free meta when everyone in the metagame discussion seemed to be enjoyed dynamax-free games while I wasn't.
 

Lionyx

first star you see tonight
is a Smogon Media Contributor Alumnus
Is Dynamax banned?
I still am able to dynamax in battles, and was disappointed because I was looking forward to dynamax-free meta when everyone in the metagame discussion seemed to be enjoyed dynamax-free games while I wasn't.
What format did you play? Dynamax was only banned from OU and the lower usage-based tiers after the recent suspect, not from every format on Showdown.
 

HoeenHero

Communication is Key!
is a Battle Simulator Administratoris a Community Leaderis a Programmeris a Community Contributoris a Live Chat Contributor
PS Admin
We were performing some intensive operations in the background that took up too many resources and caused the above issues. We have stopped it and service should be back to normal.
 
OS : Windows 10
Browser : Chrome
PS! Username : Zatch Bell King

Well so what happened was, Messages that i was sending were not visible to any other users and only i could view it, because of which bot commands also did not work. I wasn't experiencing lag cause i was running on 14mbps. Here's a screenshot http://prntscr.com/qh8i7m
 
Last edited:
I've used desktop showdown for about 2 years now, and over the past few days it's randomly become unusable. It slows down to a crawl whenever I load it up and matches basically don't load, whenever I click something it takes about 30 seconds to load and doesn't even suggest I've clicked it. Is this a common or known issue? I've started to use it in browser instead but I've got all my teams on desktop... (Windows 8, username Marowhacker or SIMP ERADICATOR)
 
Windows 7, Firefox. Can't connect to the servers this evening. Tried https and http.

The server status in first post says it's working normal so I'm asking what I can possibly try to be able to connect.

Edit: Nevermind its working again, seems there was a server restart mb.
 

HoeenHero

Communication is Key!
is a Battle Simulator Administratoris a Community Leaderis a Programmeris a Community Contributoris a Live Chat Contributor
PS Admin
Windows 7, Firefox. Can't connect to the servers this evening. Tried https and http.

The server status in first post says it's working normal so I'm asking what I can possibly try to be able to connect.

Edit: Nevermind its working again, seems there was a server restart mb.
We were down for a few minutes earlier, we should be up now.
 
I have a query - is this the right place to ask about issues regarding the use of the Showdown client/server repo available on Github?
 
1. Windows 7
2. Chrome
3. Internet Explorer and the PS application
4. a couple of days ago
5. ironedsandwich
6. Stuck at Connecting... as displayed by the screenshot above. Chrome's Inspect Element reveals two errors in order:

* Failed to load resource: net::ERR_CONNECTION_REFUSED
* Uncaught Error: SecurityError: An insecure SockJS connection may not be initiated from a page loaded over HTTPS
at new w (sockjs-1.4.0-nwjsfix.min.js:2)
at constructSocket (client.js?aa13cec8:716)
at reconstructSocket (client.js?aa13cec8:762)
at w.socket.onclose (client.js?aa13cec8:773)
at w.r.dispatchEvent (sockjs-1.4.0-nwjsfix.min.js:2)
at w.<anonymous> (sockjs-1.4.0-nwjsfix.min.js:2)

already tried: turning off firewall, resetting router, dns flush, resetting computer, uninstalling and reinstalling Chrome, clearing cache. I am not on any proxies.

Update: I managed to get back on ps by switching to a different wifi connection
 
Last edited:

HoeenHero

Communication is Key!
is a Battle Simulator Administratoris a Community Leaderis a Programmeris a Community Contributoris a Live Chat Contributor
PS Admin
1. Windows 7
2. Chrome
3. Internet Explorer and the PS application
4. a couple of days ago
5. ironedsandwich
6. Stuck at Connecting... as displayed by the screenshot above. Chrome's Inspect Element reveals two errors in order:

* Failed to load resource: net::ERR_CONNECTION_REFUSED
* Uncaught Error: SecurityError: An insecure SockJS connection may not be initiated from a page loaded over HTTPS
at new w (sockjs-1.4.0-nwjsfix.min.js:2)
at constructSocket (client.js?aa13cec8:716)
at reconstructSocket (client.js?aa13cec8:762)
at w.socket.onclose (client.js?aa13cec8:773)
at w.r.dispatchEvent (sockjs-1.4.0-nwjsfix.min.js:2)
at w.<anonymous> (sockjs-1.4.0-nwjsfix.min.js:2)

already tried: turning off firewall, resetting router, dns flush, resetting computer, uninstalling and reinstalling Chrome, clearing cache. I am not on any proxies.

Update: I managed to get back on ps by switching to a different wifi connection
Thank you for the very detailed report. This issue appears to crop up every once in a while and I haven't been able to duplicate it/get someone else with the issue till now.

Specifically a staff member had this issue this morning too. We did some poking around and discovered that their workplace had blocked the websocket ( https://sim3.psim.us/showdown/ ) which somehow results in the above error message instead of one that more clearly represents the situation. Try visiting the websocket URL above, you should get "Welcome to SockJS!", if its blocked thats your issue (and obviously we can't unblock showdown on other's networks). If thats not it reply again and let us know.
 
Try visiting the websocket URL above, you should get "Welcome to SockJS!", if its blocked thats your issue (and obviously we can't unblock showdown on other's networks). If thats not it reply again and let us know.
Thank you. It does not work on the wifi this was happening on. I have been using an internet provider which PS works fine on but they have (I don't know the technical details of this part) added Plume as an upgraded version, and it's blocked when I'm using Plume.
 

HoeenHero

Communication is Key!
is a Battle Simulator Administratoris a Community Leaderis a Programmeris a Community Contributoris a Live Chat Contributor
PS Admin
I HAVE reloaded and relogged. My Showdown says I'm offline. But I'm logged in. SOMEONE PLEASE HELP MEEEEE. Thank you!
I've merged your post with the proper thread. I need you to first take a breath and calm down. Next can you please head to the first post of this thread (link: https://www.smogon.com/forums/threa...nal-post-before-posting.3469929/#post-4329084 ), read it, and reply with the information we need to understand and fix your issue. Be as detailed as possible.
 
  1. Windows 10
  2. Brave (Chromium)
  3. Has happened on Chrome in the past
  4. A couple years ago, but got very bad recently.
  5. BallisticLG
  6. I seem to only be able to connect to the sim for short periods of time on my PC. I can connect for as long as I want to on my laptop, but my PC only stays connected for a minute before disconnecting me. I've had this error in the past, but never to the magnitude of just a minute (I'd usually disconnect after half an hour or so, and that didn't bother me at that point). Showdown is practically unplayable for me now, especially when building.
Fwiw other showdown servers such as Sports work fine and let me connect for however long I want to, it seems to be a problem with the main server for me.
 
Hey everyone. Since yesterday i cant use showdown on my phone anymore, i accidentally had on a vpn and then it told me to turn it off so i did. Ever since i cant do anything on the site, it loads in entirety but clickable buttons (username, pick team and start random battle) so i cant do anything on it right now. Has my ip been blocked because of the vpn? Thank you in advance

-
Paris
 

HoeenHero

Communication is Key!
is a Battle Simulator Administratoris a Community Leaderis a Programmeris a Community Contributoris a Live Chat Contributor
PS Admin
Hey everyone. Since yesterday i cant use showdown on my phone anymore, i accidentally had on a vpn and then it told me to turn it off so i did. Ever since i cant do anything on the site, it loads in entirety but clickable buttons (username, pick team and start random battle) so i cant do anything on it right now. Has my ip been blocked because of the vpn? Thank you in advance

-
Paris
Can you try opening https://sim3.psim.us/showdown/ ? It should say "Welcome to SockJS!" If you get anything else it means your network is blocking us. That would be an issue on your end unfortunately.
 
Can you try opening https://sim3.psim.us/showdown/ ? It should say "Welcome to SockJS!" If you get anything else it means your network is blocking us. That would be an issue on your end unfortunately.
Thank you!. It does say welcome to sockjs! I also thought my ips had blocked it but i checked and that isnt the case either. Was just at a friends house and it worked fine there, and now back home it works again too. Very strange but thank you nonetheless. The link is very helpful :)
 
  1. Windows 10 v. 1909
  2. Chrome v. 80.0.3987.149
  3. MS Edge (issue happens there as well)
  4. about a week ago
  5. RuepelNr1
  6. Pretty consistent disconnects from showdown (Generic You have been disconnected from pkm showdown)
also tried deleting cookies. this issue occurs with and without using a proxy.
 

Users Who Are Viewing This Thread (Users: 1, Guests: 0)

Top