Bug Reports v3 [READ ORIGINAL POST before posting]

In uno, if you play a wild or wild +4, and you use the command /uno hand, it will hide the color selection box, preventing you from playing and as a result will disqualify you for not moving if an autodq is on. Not sure if this was the best place to put it but it didn't fit into any of the other topics.
 
Doubles OU isn't triggering Recycle properly after the 1st successful Recycle of a Psychic Seed while Psychic Terrain is activated. It recycles as a ( found a !) and the item doesn't load into command prompts properly afterwards.
This should now be fixed. Thanks for reporting it!
 
Context: In RBY, toxic poison reverts back to regular poison when a Pokemon switches out.

While the reverted regular poison dealt a constant -6% damage to my Alakazam, the UI still used the TOX marker, while saying "Next damage: 12%/18%/etc."; this was a bit confusing. I swear it used to go from "TOX" -> "PSN" on the switch before; what happened, exactly?

Honestly just a minor UI bug if anything
https://replay.pokemonshowdown.com/gen1ou-941286746
 
Context: In RBY, toxic poison reverts back to regular poison when a Pokemon switches out.
Happens in the real game. It did that up to gen 3. Not a bug, but it's weird.
EDIT:
While the reverted regular poison dealt a constant -6% damage to my Alakazam, the UI still used the TOX marker, while saying "Next damage: 12%/18%/etc."; this was a bit confusing. I swear it used to go from "TOX" -> "PSN" on the switch before; what happened, exactly?
This one is a bug though.
 
Using TAB in a regular room allows you to auto-fill a users name starting with the current text yoiu have

but for some reason using TAB in a bttle room to autofill a username adds a space before the name, eg.

If i type Hi draTAB in a reg room itll fill
Code:
Hi dragonmirror
if i type Hi draTAB in a battle room itll fill
Code:
Hi  dragonmirror
dragonmirror

just a nitpick but a bug nonetheless
 
I've just had an issue with defeatist which proccessed while my Archeops was at 57% HP while it's supposed to only apply under 1/2 of max HP
 
So uhh, since I can't send images on PS I'll report it here.

As you can see, my name is grey, when I'm online, not AFK or idle. Since you can't send images on PS, there was no way to find out there, so I'm sending this here. If it is a bug, this needs (cough I mean should) be fixed
Edit: Alright let's try the image again.
185174
 
Last edited:

pre

shaving yaks and herding cats
is a Battle Simulator Administratoris a Community Leaderis a Programmer
PS Leader
https://replay.pokemonshowdown.com/gen7followtheleader-942394383 battle lasted 1000 turns because the endless battle clause could not correctly activate. basically leppa recycle on one side never losing hp or pp from switching on the other side is not triggering the endless battle clause
Please read over the specification for the Endless Battle Clause and let me know which clause was broken. At a glance, no side appears to have been inflicted-stale and so everything looks to be working as intended.
 
Please read over the specification for the Endless Battle Clause and let me know which clause was broken. At a glance, no side appears to have been inflicted-stale and so everything looks to be working as intended.
My pokemon was forced into a stale state, but my opponent was stale because of their switching, and was never really forced.

I'll leave a replay of what should be the behavior: https://replay.pokemonshowdown.com/gen7anythinggoes-855676453 "Ditto isn't losing PP or HP from repeatedly switching. If this continues, it will be classified as being in an endless loop"
 

pre

shaving yaks and herding cats
is a Battle Simulator Administratoris a Community Leaderis a Programmer
PS Leader
My pokemon was forced into a stale state, but my opponent was stale because of their switching, and was never really forced.
Nothing in this battle is inflicted-stale AFAICT. Heal Pulse/Floral Healing was not used, and the Leppa Berry did not switch sides from what I can see from searching (please point me to the exact turn this occurred if I'm mistaken, I'm not sitting through an 1000 turn battle, sorry). Furthermore, repeated switching does not make a side stale through the new specification, so by my interpretation I see one side with internal staleness and the other side not stale at all which is why the battle did not end before turn 1000. Even if the side with the Leppa Berry was inflicted-stale, that's still only one side which is stale and so the battle would not end early in that scenario either.

I'll leave a replay of what should be the behavior: https://replay.pokemonshowdown.com/gen7anythinggoes-855676453 "Ditto isn't losing PP or HP from repeatedly switching. If this continues, it will be classified as being in an endless loop"
This replay is from the old, implementation-defined version of the Endless Battle Clause which was significantly more aggressive but which was opaque to users and resulted in numerous false positives. The new Endless Battle Clause is implemented per the specification I linked in my prior response. I think your interpretation of 'stale' is being influenced by the old implementation which is no longer relevant.
 

Aurella

Autumn Priestess
is a Pre-Contributor
- /back doesn't recognize when you've had blockpm or bch ticked in the UI

- returning to activity from idle isn't changing right-corner name colour back from gray
 
I don't receive challenges on SD, i tried with more than one account, and it works randomly... i've already asked HoeenHero, who tried to help me, and at first glance it looked fixed cuz i got his challenges twice, but it still looks broken. It basically works like if i chall back my opponet when he has already sent the challenge, he sees mine and i can see his, but if i don't challenge him back i dont receive nothing... it started one week ago when i was gonna play for PU grand slam, and i thought it was just a bug, but since it hasn't started working properly im writing here. Btw i've already tried using more devices to be challenged (laptop and phone) but it doesn't work on both of them. My main account on SD is "the hunterr" i dunno if you need it, just in case tho i write it here. Thanks for helping, and sorry for disturb.

Hoeen Edit:
Client is receiving a valid |updatechallenges| message, but not displaying the box you get in a PM when you receive a challenge.
 
Last edited by a moderator:

Users Who Are Viewing This Thread (Users: 2, Guests: 0)

Top